Diese Hilfe bezieht sich auf die nicht mehr unterstützte untermStrich X (10) und X.1 (11).
Zur Hilfe für untermStrich X2 wechseln

JAVA™ am Server installieren

:!: ACHTUNG: ANLEITUNG OHNE GEWÄHR.
Die Firma untermStrich software gmbh übernimmt keine Haftung für etwaige Schäden oder Fehler die direkt oder indirekt durch die Benutzung oder nicht Benutzung dieser Anleitung entstehen!
:!: ACHTEN SIE AUF DIE SICHERHEIT IHRES SERVERS!!
Java muss wie auch untermStrich aktuell gehalten werden. Dies gilt besonders, wenn der Server im Internet verfügbar sein soll.

 

:!: Wenn kein Java am Server eingerichtet ist, können keine PDF basierte Auswertungen erstellt, Emails entpackt und XLSX genutzt werden.

Testen

Zum Testen gehen Sie in den Bereich „Konfigura­tion“ > „System“ > „Externe Systeme“

Java testen

und wählen Sie „Angaben testen“.

In Ordnung

Es muss ein grüner Haken erscheinen.

:?: Sie benötigen mindestens „Unternehmer plus“ auf „Konfigura­tion“ um Zugriff auf „System“ zu erhalten.

Installation

Windows

Java 7

Java 8 auf Windows 7 / Server 2008

Bei Java 8 oder speziell unter aktuelleren Windows Versionen kann es vorkommen, dass nach der Installation von Java, Java dennoch nicht verfügbar ist.

Mac OS X

Bis Mac OS X 10.8

Ab Mac OS X 10.9

Ab 10.9 müssen Sie das JDK installieren um JAVA auf der Konsole zur Verfügung zu haben.

Laden Sie dazu bitte das „Java SE JDK“ von http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html herunter.

Wählen Sie „Accept License Agreement“ und dann jdk-8u…-macosx-x64.dmg.

Ubuntu

sudo apt-get install openjdk-7-jre-headless

Andere Linux Systeme

Ältere SUSE

Laut Meldung eines Kunden, installieren Sie bitte auch:

  • xorg-x11-fonts-core
  • xorg-x11-fonts
  • fonts-config
  • ft2demos
  • dom4j
  • saxon9
Fonts

Stellen Sie sicher, dass fontconfig bzw fonts-config installiert ist.

GCC_4.2.0 not found

Wenn Java installiert ist, der Test aber fehlschlägt, öffnen Sie bitte das Apache error_log.

Wenn Sie die folgende Fehlermeldung erhalten, haben Sie im lib Pfad des Apache eine veraltete libgcc_s.so.1:

java: /…/lib/libgcc_s.so.1: version `GCC_4.2.0' not found (required by /usr/lib/libgcj.so.8rh)

Auf einem System konnten wir dazu die Systemdatei /lib/libgcc_s.so.1 über die bestehende Datei kopieren.

Melden Sie sich an, um einen Kommentar zu erstellen.