Systemanforderungen

Client (PC oder Smartphone)

Die folgenden Erwartungen stellen wir an den Client, um untermStrich benutzen zu können:

  • Betriebssystem: Windows 1), Mac OS X 2), Linux, Android, iOS (iPhone / iPad) - Beachten Sie bitte die unterstützen Browser.
  • Die folgenden Module benötigen den Connector 4VX:

    Folgende Funktionen benötigen den Connector 4VX:

    Der Connector 4VX benötigt das .NET Framework ab 4.

    • Unterstützt werden Microsoft Office 2000 - 20078)9) 2010 - 2016
      • 32/64Bit (32Bit empfohlen!)
      • Outlook 2016: Standard MAPI wird nicht unterstützt.
      • Online-Varianten werden nicht unterstüzt.
    • Unterstützt werden Windows 7, 8, 8.1, 10.
      • :!r: Windows 10 unterstützt alle Bereiche, außer Erwei­terte Auswer­tungen 4VX 10) und Ressourcen 4VX.

    :!: Aktualisieren Sie bitte den Connector 4VX auf die .NET 4 Variante, bevor Sie auf Windows 8.1 oder höher aktualisieren.

     
  • Der eingeschränkte Connector für Java™ Webstart benötigt Java 1.7 oder neuer (Verfügbar ab Windows 7, Mac OS X 10.7.3, Ubuntu Linux 10.04).
  • ODT/ODS Funktionen unterstützen LibreOffice 3.5 - 5.
  • Netzwerk: Anbindung an den Server mittels LAN, WLAN, DSL, mobiles Internet (HSDPA), VPN

Browser

Um auf untermStrich zuzugreifen benötigen Sie einen aktuellen Browser auf jedem Arbeitsplatz PC bzw. Smartphone oder Tablet.

:righty: Browser, was sind denn jetzt noch mal Browser? auf Internet-fuer-Architekten.de

Desktop Browser

Mobile Browser

Auf mobilen Systemen ist kein Connector und auch kein eingeschränkter Connector für Java™ Webstart nutzbar.

  • Apple
  • Android
    • Android Browser ab Android 4.1
    • Opera Mobile ab 24
    • Firefox Mobile ab 32
 

Server

Der Server sollte etwas besser ausgestattet sein und muss das folgende erfüllen:

  • Betriebssystem:
    • Windows
      • Windows 7, 8, 8.1, 10, Server 2008 R2, Server 2012, Server 2012 R2, Server 2016
        • Wenn Sie einen Virenscanner einsetzen, stellen Sie sicher, das die untermStrich und MySQL Verzeichnisse bzw. der Apache und MySQL Dienst ausgenommen sind: Ausnahmen für Virenscanner
    • Linux
        • Ubuntu Server Precise Pangolin 12.04, Trusty Tahr 14.04 12)
      • Nicht mehr: untermStrich X:
        • Ubuntu Server Precise Pangolin 12.04 13)
      • Verwenden Sie keine LAMP Pakete die nicht vom Distributor des Betriebssystems stammen (Wie xampp)
      • Bei anderen Distributionen und Versionen können wir Ihnen leider keine Unterstützung durch unseren Support garantieren.
    • Mac OS X
      • Nicht mehr: 10.8, 10.9,14)
      • 10.10, 10.11 - Empfehlung: ab 10.10 15)
      • 10.12 ab untermStrich 11.6
        • :righty: Updaten Sie untermStrich unbedingt auf 11.6, bevor Sie den Mac Server auf macOS Sierra 10.12 updaten!
      • Verwenden Sie keine MAMP Pakete. Nutzen Sie das eingebaute Apache/PHP und stellen Sie sicher, dass Port 80 und 443 zur Verfügung stehen (Kerio muss so konfiguriert werden, dass Port 80 und 443 für den in macOS integrierten Apache zur Verfügung stehen.).
  • Software:
      • PHP
      • MySQL 5.5, 5.6 oder 5.719)
    • Nicht mehr: untermStrich X:
      • PHP 5.3, 5.4
      • MySQL 5.5 oder 5.6
    • Apache 2
    • Java ab Version 1.7
    • PDF Erstellung über LibreOffice“ benötigt LibreOffice 3.5 - 5.
  • Prozessor: 2-Kern Intel/AMD, Kein ARM
  • Speicher: 2 GB Ram (1 GB davon exklusiv für MySQL 20), 1GB für Apache)
  • Festplatte/SSD: 120 GB und mindestens 3% der Kapazität der Partition. (Für maximale/optimale Performance empfehlen wir den Einsatz einer SSD oder einer schnellen Server-Festplatte)
  • Grafikkarte: egal
  • Netzwerk: 100 MBit, 1 GBit
  • Der Server muss zum Einspielen von untermStrich Updates Zugang zum Internet haben. 21)

:!: Ausserdem wird empfohlen, eine Hardware-Firewall einzusetzen und passend zu konfigurieren, um den Server nicht nach außen ungewollt zu exponieren und eine Sicherheitslücke zu öffnen.

Notwendige Apache / PHP Module

Die folgenden Informationen sind als Hilfe für Ihren Systembetreuer gedacht. Installation siehe Installationsbeispiele.

Diese Module / Einstellungen sind häufig schon vorhanden oder werden zum Beispiel durch unser Server Setup Tool eingerichtet.

  • Apache 2
    • mod_rewrite
    • mod_expires
    • mod_env
    • Einstellungen:
      • AllowOverride All für das Verzeichnis
  • PHP
    • php_xsl
    • php_mysqli
    • zip
    • Einstellungen:
      • register_globals = Off
      • safe_mode = Off
      • magic_quotes_gpc = Off
      • magic_quotes_runtime = Off
      • max_execution_time >= 30
      • memory_limit >= 128M
      • file_uploads = On
      • upload_max_filesize >= 20M
      • post_max_size >= 30M
      • max_input_time >= 60
      • Die Werte upload_max_filesize und post_max_size bestimmen die maximale Größe der mit untermStrich X verwaltbaren Dateien. Weitere Details

Notwendige MySQL Engines

  • MyISAM
  • INNODB
  • ARCHIVE
  • MEMORY

E-Mail Server

Die folgenden E-Mail Server wurden für den IMAP/SMTP Zugriff von untermStrich 22) getestet:

  • 1&1 Serverdienste - 1&1 MailXchange, GMX.at/de/ch, WEB.de
  • Google Serverdienste - Gmail 23)
  • Microsoft - Exchange 2010, 2013
  • Microsoft - Office 365
  • Alt-N Technologies - MDaemon

:righty: Hinweise zu Exchange
Die SMTP Authentifizierung ist per LOGIN, CRAM-MD5 24) und PLAIN 25) möglich. NTLM ist nicht möglich. (Informationen zu Exchange und NTLM)

Bei einer Domänen Umgebung mit MS Exchange Server ist eventuell als Benutzername der Domänen-Name vor dem Benutzernamen einzutragen (Bsp.: Domäne\Benutzername)

Wenn Sie Umlaute im Benutzernamen oder Passwort haben, können Sie versuchen diese zu ersetzen:

  • ä durch a
  • ö durch o
  • ü durch u
  • ß durch ss

:righty: Andere Server
Bei anderen E-Mail Servern und Versionen können wir Ihnen leider keine Unterstützung durch unseren Support garantieren.

 

.

.

1) Bis 10
2) Bis 10.10
3) Wird durch den Butler Schaltpult und Halbfertige Leistungen abgelöst
4) Wird durch den Typ “Beliebige Datei“ im Modul Dokumente abgelöst
5) Termine können auch per iCalendar abonnieren abgerufen werden, Adressen können auch per LDAP abgerufen werden.
6) Wird durch die E-Mail Zuordnung ersetzt
7) Beachten Sie auch die erweiterte Projekt-Auswertung
9) Office 2007 - Extended Support Ende durch Microsoft in 2017 Microsoft Support Lifecycle
10) Projekt­über­sicht 4VX wurde mit 11.5 komplett durch die Projekt­über­sicht abgelöst
11) Die aktuellste Version unter Windows ist 5 und diese ist fehlerhaft
12) , 13) Long Term Support (LTS) Versionen
14) Veraltet. Letztes Update für 10.9 im März 2016: https://support.apple.com/en-us/HT201222
15) Da dafür MySQL 5.6 verfügbar ist.
16) Ausnahme: PHP 5.3 auf Ubuntu Server Precise Pangolin 12.04 https://wiki.ubuntu.com/Releases bis April 2017
18) 5.6 ab untermStrich 11.3 - Auf Linux und Apache Bundle
19) 5.7 ab untermStrich 11.3
20) Beachten Sie: Der Microsoft Exchange Server 2010/ 2013 nutzt den gesamten verfügbaren Speicher(RAM). Details
22) Für die E-Mail Zuordnung als auch für das direkte Versenden über die Weboberfläche - Ohne Outlook
23) Das Verzeichnis “[Gmail]“ kann nicht durchsucht werden. Das Ausgangsverzeichnis “[Gmail]/Gesendet“ wird jedoch automatisch erkannt.
24) Ab 10.8.5.7304
25) Ab 11.7.5.12510
Melden Sie sich an, um einen Kommentar zu erstellen.